Commentary feature - Turn off moderation by enabling restricted words Answered

Post author
Simon Späti

I am testing the commentary feature, which I'm very excited about. A question about moderation: The only way I found to turn off moderation is by disabling restricted words. 🤔 (Might be a small bug?)

I'd like to turn off moderation but still keep restricted words. If restricted words (marked above) are toggled on, each comment needs approval/moderation. Maybe I understand wrong, but I would only assume approval if I checked the first checkmark. But that was not the case.
 
I'd like the new commentary feature. Is that working with a static-generated website? If so, do you have an HTML Boilerplate as the Webflow component does not show any code 😞
 
I'm trying to reverse engineer based on your live website, but not much luck yet:
<div class="comment-container"> <div class="comment-channel" data-ms-channel="feeback" data-ms-channel-sort="oldest"> <div class="comment-card is-form"> <h2>Join the discussion</h2> <form data-ms-form="post" aria-label="New Comment Form"> <textarea class="comment-input" data-ms-post="content" placeholder="Create a new comment." autofocus spellcheck="false"></textarea> <input type="submit" class="comment-form-button" value="Send"> </form> </div> <div class="comment-section-heading"> <h3><span data-ms-post="count">Comments</span> Comments</h3> </div> <div data-ms-channel-content="!has-posts" class="comment-empty-state"> <div>Be the first to leave a comment.</div> </div> <div data-ms-post-load="100" data-ms-post="container" class="comment-post-container"> </div> </div> </div>
 
Any boiler or hint would be much appreciated. Thank you
 
published a version here: https://www.dedp.online/appendix/feedback.html :)
 
I reverse engineered from generated webflow (with a free version) to this, it works, not sure if it's correct (I'm guessing it's way too long?)
 
commentary-example.html 
​<script>
.comment-thread-sort {
  align-self: stretch;
}
 
Besides, the HTML is so long and probably has too much, I also found that when I'm logged in, it will always directly jump to the end of the page, which is very bad for a book where you start at the top.
 
But it happens only when logged in.. any idea?  🤔
 

Comments

6 comments

  • Comment author
    Duncan Hamra

    Simon Späti this is happening because one of the inputs is set to autofocus.
    https://developer.mozilla.org/en-US/docs/Web/HTML/Global_attributes/autofocus

    Remove that and you should be good to go! 

    0
  • Comment author
    Simon Späti

    That was it 💙. Thanks so much, Duncan Hamra. Always learn new HTML tags Setting it to false didn't help; I had to remove it entirely.

    And it's correct, that you do not have a minimal HTML example for the commentary feature, or does my example look good? (at least it seems to work, but not sure if there are some hard-coded things as I copied the compiled HTML from a Webflow-generated site 😅 )

    0
  • Comment author
    Duncan Hamra

    Your example looks great!! Awesome work.

    0
  • Comment author
    Dominic Quiros

    You are making a comments section?

    I am working on this for a client right now as their current set up does not work properly

    0
  • Comment author
    Simon Späti

    Dominic Quiros Yes I used the Commenting feature, and it works well. Any specific that did not work?

    0
  • Comment author
    Dominic Quiros

    I just realized this was wized not the Webflow one

    But I will check out this commenting feature Wized can provide

    Need to fix a clients website

    0

Please sign in to leave a comment.